Kaspersky Security Center が WSUS サーバーとして使用されていると Microsoft Store からアプリケーションがダウンロードされない理由
更新日: 2024年2月1日
Article ID: 15883
本記事の対象となるアプリケーションとバージョンを表示する
- Kaspersky Security Center 14.2(バージョン 14.2.0.26967)
- Kaspersky Security Center 14(バージョン 14.0.0.10902)
- Kaspersky Security Center 13.2(バージョン 13.2.0.1511)
- Kaspersky Security Center 13.1(バージョン 13.1.0.8324)
- Kaspersky Security Center 13(バージョン 13.0.0.11247)
問題
Kaspersky Security Center が WSUS サーバーとして使用されていると、ここで管理されているデバイスはすべて、Microsoft Store からアプリケーションをダウンロードできなくなります。
原因
Microsoft による制限によるものです。詳しくは、Microsoft の Web サイト (英語) をご覧ください。
解決方法
インターネットからアップデートをダウンロードすることをワークステーションに許可するには、次の手順を実行します:
- 使用しているユーザーアカウントに管理者権限が付与されていることを確認します。
- Kaspersky Security Center Administration Server サービスを一時停止します。
- コマンドラインを実行します。
- klscflag.exe ツールへのパスを指定します。既定では、このツールは Kaspersky Security Center のインストールフォルダー内にあります:
C:\Program Files (x86)\Kaspersky Lab\Kaspersky Security Center - 以下のコマンドを実行します:
klscflag.exe -fset -pv klserver -n KLWUS_WUA_DISABLE_CONN_TO_INET -t d -v 0
- Kaspersky Security Center Administration Server サービスを再開します。
引き続き Kaspersky Security Center を使用してアップデートをワークステーションに配布する場合は、以前の設定を復元します。
- Kaspersky Security Center Administration Server サービスを一時停止します。
- コマンドラインを実行します。
- klscflag.exe ツールへのパスを指定します。既定では、このツールは Kaspersky Security Center のインストールフォルダー内にあります:
C:\Program Files (x86)\Kaspersky Lab\Kaspersky Security Center - 以下のコマンドを実行します:
klscflag.exe -fset -pv klserver -n KLWUS_WUA_DISABLE_CONN_TO_INET -t d -v 1
- Kaspersky Security Center Administration Server サービスを再開します。